通达信公式参数怎么设置,这个通达信公式如何修改呀,那参数如何设置才能测试通过呢?

Q1:这个通达信公式如何修改呀,那参数如何设置才能测试通过呢?

{通达信测试通过}
N:=13;
M:=3;
P:=30;
DIF:EMA(CLOSE,6)-EMA(CLOSE,13);
DEA:EMA(DIF,5);
MACD:(DIF-DEA)*2,COLORSTICK;
DRAWTEXT(REF(MACD,1)>0 AND MACD<0,MACD-0.01,'1');
DRAWTEXT(REF(MACD,2)>0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'2');
DRAWTEXT(REF(MACD,3)>0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'3');
DRAWTEXT(REF(MACD,4)>0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'4');
DRAWTEXT(REF(MACD,5)>0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'5');
DRAWTEXT(REF(MACD,6)>0 AND REF(MACD,5)<0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'6');
绿线天:=BARSLAST(CROSS(DEA,DIF));
红线天:=BARSLAST(CROSS(DIF,DEA));
压力:REF(H,绿线天),NODRAW;
支撑:REF(O,红线天),NODRAW;
A2:=IF(CROSS(0,DEA),1,0);
A12:=IF(DIF>0 AND CROSS(DIF,DEA),1,0);
SS2:=IF(A2,SUM(A12,0),0);
SSB2:=HHV(SS2,0);
SSS2:=SUM(A12,0);
轴上第1次金叉:IF(SSS2-SSB2=1 AND SSS2>REF(SSS2,1),1,0),NODRAW;
DRAWICON(轴上第1次金叉,0.2,1);
破0轴: REF(DIF,1)>0 AND DIF<0,COLORGREEN,NODRAW;
DRAWICON(破0轴,0.1,2);
第四根绿柱:REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3) <=0 AND MACD<=0 AND REF(MACD,4) >=0,COLORRED,NODRAW;
DRAWICON(第四根绿柱,0,11);
好趋势2:=MA((3*SMA((C-LLV(L,M))/(HHV(H,M)-LLV(L,M))*100,3,1)),2)
-MA((2*SMA(SMA((C-LLV(L,M))/(HHV(H,M)-LLV(L,M))*100,3,1),3,1)),2);
动态底部2:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)
/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好趋势2<REF(好趋势2,1)
AND 好趋势2<50,-5,-2.5);
好趋势:=MA((3*SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,3,1)),2)
-MA((2*SMA(SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,3,1),3,1)),2);
动态底部:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)
/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好趋势<REF(好趋势,1)
AND 好趋势<50,-5,-3);
买警:=IF(好趋势<=-3 AND 好趋势<REF(好趋势,1),-5,
IF(好趋势<=0 AND 好趋势<REF(好趋势,1),-4.9,
IF(好趋势<=3 AND 好趋势<REF(好趋势,1),-4.8,
IF(好趋势<=6 AND 好趋势<REF(好趋势,1),-4.6,
IF(好趋势<=9 AND 好趋势<REF(好趋势,1),-4.4,
IF(好趋势<=12 AND 好趋势<REF(好趋势,1),-4.2,
IF(好趋势<=15 AND 好趋势<REF(好趋势,1),-4.0,
IF(好趋势<=18 AND 好趋势<REF(好趋势,1),-3.8,
IF(好趋势<=21 AND 好趋势<REF(好趋势,1),-3.6,
IF(好趋势<=24 AND 好趋势<REF(好趋势,1),-3.4,
IF(好趋势<=27 AND 好趋势<REF(好趋势,1),-3.2,
IF(好趋势<=30 AND 好趋势<REF(好趋势,1),-3.1,0))))))))))));
CROSS(动态底部,-4) AND CROSS(动态底部2,-4) AND REF(买警,1)<-P/10
AND DYNAINFO(39)>0 AND DYNAINFO(17)>0 AND C<20;

Q2:通达信指标参数如何用公式表达

m1:=5,
m2:=35,

Q3:如何调整通达信软件里的指标参数

参数如何植入公式,有两种方式
方式一,在使用过程中可通过ALT+R即时调整参数,而不必打开公式
缺省值,就是目前正在使用的数值
方式二,只能在编辑公式的界面里调整,不适合对公式完全不懂的同学

Q4:通达信参数怎么设置

是公式的参数吗?
在K线分析界面,点右键——当前指标——调整指标参数

Q5:通达信选股公式中,怎样表示均线的向上形态

二楼说的是技术选股,不是解释。
其实“均线的向上形态”是一个动态的东西,没有非常精准的解释,更不好用公式来界定。
“均线的向上形态”重要的是如何应用。
应该说“均线的向上形态”很好判断,即楼主所说的均线“保持走平或者向上”,不论多长时间段的均线都会出现这种现象。但你要把长、中、短期均线合成为一个系统,通过它们之间的相互关系来对股价未来趋势进行判断。
具体地说,这个系统可以这样运用:
不同周期的均线结合在一起,技术上有不同的意义。均线长期在低位平躺,类似一条水平线的个股,容易形成宽阔扎实的底部。从形态上看,股价经过长期深幅的调整之后出现放量反弹,并企稳在30日线上方,其后不断有成交量温和放大现象,并主动放量上攻触及120日均线,投资者即可等待30日、60日均线走平粘合后进入。股价若能同时站稳在120日均线上方,则意味着中长期趋势的逆转。例如菲菲农业自2001年6月之后一直处在调整格局之中,股价跌幅达到70%。今年8月份之后30日均线慢慢走平,9月29日之后成交量骤然放大,股价开始企稳在30日、60日均线上方,并一度触及120日均线,显示中线买入机会已悄然来临。
在符合上述条件的个股中,若目前价位已远离前期密集成交区、前期高点、整理平台这些阻力区,长短均线在低位长时间粘合,股价在均线上下来回震荡,某天股价放大量拉出长阳线,或是向上跳空形成突破缺口,30日线支撑有力且仍保持上升趋势。此时往往是最佳买点。
20日、30日向右上角爬行且呈两线保持平行状态,是安全的持股信号。若30日均线保持上升趋势可一路持有,该线不宜出现拐点,若出现,立即离场。良好的均线形态应是短中长期均线均保持同步平行匀速向上的,这样的涨势长久而稳健。均线系统“过分向上发散,意味已进入快速上扬期,升势可能难以持续。短中长期均线之间的乖离率过大,也意味着短线利润丰厚,随时可能转势或出现回档调整。
股价运行在120日、250日均线之间,两条均线成剪刀之态势,说明股价上行乏力。此时下行的一般是250日均线,上行的120日均线。根据均线原理,此时120日周期的持股成本在上升,250日持股者成本在下降,随着股价上升,一方面面临长线买家套现的压力,另一方面主力成本与市场成本同步递增,抛压将会越来越大,犹如推着石头上山,注定升势难以持续。
在均线形态分析中要注意,关于120日、250日均线的作用还体现在分时之中,而且短线效果更加明显。在均线应用中,短周期用长期参数,长周期用短期参数经常会有意想不到的效果出现。例如在五分钟图中,使用120、250的参数,常能寻找到较佳的买点。

Q6:通达信选股公式,表示均线向上

count(ma(c,N)>=ref(ma(c,n),1),M)=M;{N为均线周线,选5代表5日均线,M为均线形态周期,选10表示连续10日走平或向上,如果只要向上不要走平的话,就把ref(ma......前的等号删去}